import re
regex = re.compile(r"#000#000#000(?<call_date>[0-9]{6})\s{6}(?<call_time>[0-9]{4})(?<call_duration>[0-9]{4}).{9}(?<dialed_num>.{15})(?<calling_num>.{10})", flags=re.MULTILINE)
test_str = ("#000#000#000031819 110100227 8*902 15709748756 77373 88888 0 0174 77373 0 0000215 #015\n"
"#000#000#000031819 11010007C 714012035854353 5010 0 54353 0 0000045 #015")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")