package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)#000#000#000(?<call_date>[0-9]{6})\s{6}(?<call_time>[0-9]{4})(?<call_duration>[0-9]{4}).{9}(?<dialed_num>.{15})(?<calling_num>.{10})`)
var str = `#000#000#000031819 110100227 8*902 15709748756 77373 88888 0 0174 77373 0 0000215 #015
#000#000#000031819 11010007C 714012035854353 5010 0 54353 0 0000045 #015`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}