// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)#000#000#000(?<call_date>[0-9]{6})\s{6}(?<call_time>[0-9]{4})(?<call_duration>[0-9]{4}).{9}(?<dialed_num>.{15})(?<calling_num>.{10})").unwrap();
let string = "#000#000#000031819 110100227 8*902 15709748756 77373 88888 0 0174 77373 0 0000215 #015
#000#000#000031819 11010007C 714012035854353 5010 0 54353 0 0000045 #015";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}