using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#000#000#000(?<call_date>[0-9]{6})\s{6}(?<call_time>[0-9]{4})(?<call_duration>[0-9]{4}).{9}(?<dialed_num>.{15})(?<calling_num>.{10})";
string input = @"#000#000#000031819 110100227 8*902 15709748756 77373 88888 0 0174 77373 0 0000215 #015
#000#000#000031819 11010007C 714012035854353 5010 0 54353 0 0000045 #015";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}