import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#000#000#000(?<call_date>[0-9]{6})\\s{6}(?<call_time>[0-9]{4})(?<call_duration>[0-9]{4}).{9}(?<dialed_num>.{15})(?<calling_num>.{10})";
final String string = "#000#000#000031819 110100227 8*902 15709748756 77373 88888 0 0174 77373 0 0000215 #015\n"
+ "#000#000#000031819 11010007C 714012035854353 5010 0 54353 0 0000045 #015";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}