import Foundation
let pattern = ##"#000#000#000(?<call_date>[0-9]{6})\s{6}(?<call_time>[0-9]{4})(?<call_duration>[0-9]{4}).{9}(?<dialed_num>.{15})(?<calling_num>.{10})"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#000#000#000031819 110100227 8*902 15709748756 77373 88888 0 0174 77373 0 0000215 #015
#000#000#000031819 11010007C 714012035854353 5010 0 54353 0 0000045 #015
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)