#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^.*_Page)\d+\.jpg$(?!\r?\n\1\d+\.jpg$)"
Local $sString = "A_File1_Page1.jpg" & @CRLF & _
"A_File1_Page2.jpg" & @CRLF & _
"" & @CRLF & _
"A_File2_Page1.jpg" & @CRLF & _
"A_File2_Page2.jpg" & @CRLF & _
"A_File2_Page3.jpg" & @CRLF & _
"" & @CRLF & _
"B_File1_Page1.jpg" & @CRLF & _
"B_File1_Page2.jpg" & @CRLF & _
"B_File1_Page3.jpg" & @CRLF & _
"" & @CRLF & _
"B_File2_Page1.jpg" & @CRLF & _
"B_File2_Page2.jpg" & @CRLF & _
"B_File2_Page3.jpg" & @CRLF & _
"B_File2_Page4.jpg" & @CRLF & _
"" & @CRLF & _
"C_File1_Page1.jpg" & @CRLF & _
"C_File1_Page2.jpg" & @CRLF & _
"C_File1_Page3.jpg" & @CRLF & _
"C_File1_Page4.jpg" & @CRLF & _
"C_File1_Page5.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")