using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^.*_Page)\d+\.jpg$(?!\r?\n\1\d+\.jpg$)";
string input = @"A_File1_Page1.jpg
A_File1_Page2.jpg
A_File2_Page1.jpg
A_File2_Page2.jpg
A_File2_Page3.jpg
B_File1_Page1.jpg
B_File1_Page2.jpg
B_File1_Page3.jpg
B_File2_Page1.jpg
B_File2_Page2.jpg
B_File2_Page3.jpg
B_File2_Page4.jpg
C_File1_Page1.jpg
C_File1_Page2.jpg
C_File1_Page3.jpg
C_File1_Page4.jpg
C_File1_Page5.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}