$re = '/(^.*_Page)\d+\.jpg$(?!\r?\n\1\d+\.jpg$)/m';
$str = 'A_File1_Page1.jpg
A_File1_Page2.jpg
A_File2_Page1.jpg
A_File2_Page2.jpg
A_File2_Page3.jpg
B_File1_Page1.jpg
B_File1_Page2.jpg
B_File1_Page3.jpg
B_File2_Page1.jpg
B_File2_Page2.jpg
B_File2_Page3.jpg
B_File2_Page4.jpg
C_File1_Page1.jpg
C_File1_Page2.jpg
C_File1_Page3.jpg
C_File1_Page4.jpg
C_File1_Page5.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);