const regex = /(^.*_Page)\d+\.jpg$(?!\r?\n\1\d+\.jpg$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^.*_Page)\\d+\\.jpg$(?!\\r?\\n\\1\\d+\\.jpg$)', 'gm')
const str = `A_File1_Page1.jpg
A_File1_Page2.jpg
A_File2_Page1.jpg
A_File2_Page2.jpg
A_File2_Page3.jpg
B_File1_Page1.jpg
B_File1_Page2.jpg
B_File1_Page3.jpg
B_File2_Page1.jpg
B_File2_Page2.jpg
B_File2_Page3.jpg
B_File2_Page4.jpg
C_File1_Page1.jpg
C_File1_Page2.jpg
C_File1_Page3.jpg
C_File1_Page4.jpg
C_File1_Page5.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}