import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^.*_Page)\\d+\\.jpg$(?!\\r?\\n\\1\\d+\\.jpg$)";
final String string = "A_File1_Page1.jpg\n"
+ "A_File1_Page2.jpg\n\n"
+ "A_File2_Page1.jpg\n"
+ "A_File2_Page2.jpg\n"
+ "A_File2_Page3.jpg\n\n"
+ "B_File1_Page1.jpg\n"
+ "B_File1_Page2.jpg\n"
+ "B_File1_Page3.jpg\n\n"
+ "B_File2_Page1.jpg\n"
+ "B_File2_Page2.jpg\n"
+ "B_File2_Page3.jpg\n"
+ "B_File2_Page4.jpg\n\n"
+ "C_File1_Page1.jpg\n"
+ "C_File1_Page2.jpg\n"
+ "C_File1_Page3.jpg\n"
+ "C_File1_Page4.jpg\n"
+ "C_File1_Page5.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}