use strict;
my $str = 'A_File1_Page1.jpg
A_File1_Page2.jpg
A_File2_Page1.jpg
A_File2_Page2.jpg
A_File2_Page3.jpg
B_File1_Page1.jpg
B_File1_Page2.jpg
B_File1_Page3.jpg
B_File2_Page1.jpg
B_File2_Page2.jpg
B_File2_Page3.jpg
B_File2_Page4.jpg
C_File1_Page1.jpg
C_File1_Page2.jpg
C_File1_Page3.jpg
C_File1_Page4.jpg
C_File1_Page5.jpg';
my $regex = qr/(^.*_Page)\d+\.jpg$(?!\r?\n\1\d+\.jpg$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}