import Foundation
let pattern = #"(^.*_Page)\d+\.jpg$(?!\r?\n\1\d+\.jpg$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A_File1_Page1.jpg
A_File1_Page2.jpg
A_File2_Page1.jpg
A_File2_Page2.jpg
A_File2_Page3.jpg
B_File1_Page1.jpg
B_File1_Page2.jpg
B_File1_Page3.jpg
B_File2_Page1.jpg
B_File2_Page2.jpg
B_File2_Page3.jpg
B_File2_Page4.jpg
C_File1_Page1.jpg
C_File1_Page2.jpg
C_File1_Page3.jpg
C_File1_Page4.jpg
C_File1_Page5.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)