import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((?<path>\\\\.+)\\\\(?<file>[^\\.]+)\\.(?<ext>[^\\)]+)\\)";
final String string = "(\\Device\\HarddiskVolume1\\Windows\\explorer.exe) attempted to load \\Device\\HarddiskVolume1\\Users\\vagrant\\Downloads\\kitty-0.74.4.6.exe ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}