re = /\((?<path>\\.+)\\(?<file>[^\.]+)\.(?<ext>[^\)]+)\)/m
str = '(\\Device\\HarddiskVolume1\\Windows\\explorer.exe) attempted to load \\Device\\HarddiskVolume1\\Users\\vagrant\\Downloads\\kitty-0.74.4.6.exe '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end