$re = '/\((?<path>\\\\.+)\\\\(?<file>[^\.]+)\.(?<ext>[^\)]+)\)/m';
$str = '(\\Device\\HarddiskVolume1\\Windows\\explorer.exe) attempted to load \\Device\\HarddiskVolume1\\Users\\vagrant\\Downloads\\kitty-0.74.4.6.exe ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);