use strict;
my $str = '(\\Device\\HarddiskVolume1\\Windows\\explorer.exe) attempted to load \\Device\\HarddiskVolume1\\Users\\vagrant\\Downloads\\kitty-0.74.4.6.exe ';
my $regex = qr/\((?<path>\\.+)\\(?<file>[^\.]+)\.(?<ext>[^\)]+)\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}