const regex = /\((?<path>\\.+)\\(?<file>[^\.]+)\.(?<ext>[^\)]+)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\((?<path>\\\\.+)\\\\(?<file>[^\\.]+)\\.(?<ext>[^\\)]+)\\)', 'gm')
const str = `(\\Device\\HarddiskVolume1\\Windows\\explorer.exe) attempted to load \\Device\\HarddiskVolume1\\Users\\vagrant\\Downloads\\kitty-0.74.4.6.exe `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}