#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*)-Nr(\d+)-(\d+,?\d*)x(\d+,?\d*)cm-(.*)(\d{4}\b)-?(\d+)?(.*)?"
Local $sString = "G22-Nr035-100x150cm-Backlight-2020" & @CRLF & _
"" & @CRLF & _
"HOLLU-Nr357-33,5x500cm-Backlight-nicht-hinterleuchtet-2021" & @CRLF & _
"" & @CRLF & _
"GRIBA-Nr651-200x300cm-Blockout-2018" & @CRLF & _
"" & @CRLF & _
"GRAMM-Nr470-200x100cm-Backlight-nicht-hinterleuchtet-2021-4Stk" & @CRLF & _
"" & @CRLF & _
"HAGELSCHUTZ-Nr1082-150x400cm-Backlight-nicht-hinterleuchtet-mit Schlaufe-2021"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")