// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*)-Nr(\d+)-(\d+,?\d*)x(\d+,?\d*)cm-(.*)(\d{4}\b)-?(\d+)?(.*)?").unwrap();
let string = "G22-Nr035-100x150cm-Backlight-2020
HOLLU-Nr357-33,5x500cm-Backlight-nicht-hinterleuchtet-2021
GRIBA-Nr651-200x300cm-Blockout-2018
GRAMM-Nr470-200x100cm-Backlight-nicht-hinterleuchtet-2021-4Stk
HAGELSCHUTZ-Nr1082-150x400cm-Backlight-nicht-hinterleuchtet-mit Schlaufe-2021";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}