import re
regex = re.compile(r"(.*)-Nr(\d+)-(\d+,?\d*)x(\d+,?\d*)cm-(.*)(\d{4}\b)-?(\d+)?(.*)?")
test_str = ("G22-Nr035-100x150cm-Backlight-2020\n\n"
"HOLLU-Nr357-33,5x500cm-Backlight-nicht-hinterleuchtet-2021\n\n"
"GRIBA-Nr651-200x300cm-Blockout-2018\n\n"
"GRAMM-Nr470-200x100cm-Backlight-nicht-hinterleuchtet-2021-4Stk\n\n"
"HAGELSCHUTZ-Nr1082-150x400cm-Backlight-nicht-hinterleuchtet-mit Schlaufe-2021")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")