import Foundation
let pattern = #"(.*)-Nr(\d+)-(\d+,?\d*)x(\d+,?\d*)cm-(.*)(\d{4}\b)-?(\d+)?(.*)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
G22-Nr035-100x150cm-Backlight-2020
HOLLU-Nr357-33,5x500cm-Backlight-nicht-hinterleuchtet-2021
GRIBA-Nr651-200x300cm-Blockout-2018
GRAMM-Nr470-200x100cm-Backlight-nicht-hinterleuchtet-2021-4Stk
HAGELSCHUTZ-Nr1082-150x400cm-Backlight-nicht-hinterleuchtet-mit Schlaufe-2021
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)