$re = '/(.*)-Nr(\d+)-(\d+,?\d*)x(\d+,?\d*)cm-(.*)(\d{4}\b)-?(\d+)?(.*)?/';
$str = 'G22-Nr035-100x150cm-Backlight-2020
HOLLU-Nr357-33,5x500cm-Backlight-nicht-hinterleuchtet-2021
GRIBA-Nr651-200x300cm-Blockout-2018
GRAMM-Nr470-200x100cm-Backlight-nicht-hinterleuchtet-2021-4Stk
HAGELSCHUTZ-Nr1082-150x400cm-Backlight-nicht-hinterleuchtet-mit Schlaufe-2021';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);