using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)-Nr(\d+)-(\d+,?\d*)x(\d+,?\d*)cm-(.*)(\d{4}\b)-?(\d+)?(.*)?";
string input = @"G22-Nr035-100x150cm-Backlight-2020
HOLLU-Nr357-33,5x500cm-Backlight-nicht-hinterleuchtet-2021
GRIBA-Nr651-200x300cm-Blockout-2018
GRAMM-Nr470-200x100cm-Backlight-nicht-hinterleuchtet-2021-4Stk
HAGELSCHUTZ-Nr1082-150x400cm-Backlight-nicht-hinterleuchtet-mit Schlaufe-2021";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}