#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[\[,])\s*(['\"])(?:(\1)|.)*?\1(?=\s*[,\]])"
Local $sString = "[ "A", ""B"",'C' , " D"]" & @CRLF & _
"[ "A", "'B'",'C' , " D"]" & @CRLF & _
"[ "A", ''B'','C' , " D"]" & @CRLF & _
"[ "A", '"B"','C' , " D"]" & @CRLF & _
"[ "A", '8 o'clock','C' , " D"]" & @CRLF & _
"[ "A", "Ol' 8 o'clock",'C' , " D"]" & @CRLF & _
"" & @CRLF & _
"["Some Text"]" & @CRLF & _
"["Some more Text"]" & @CRLF & _
"["Even more text about \"this text\""]" & @CRLF & _
"["Ol' 8 o'clock"]" & @CRLF & _
"['8 o'clock']" & @CRLF & _
"[ '8 o'clock']" & @CRLF & _
"['Ol' 8 o'clock']" & @CRLF & _
"[""B"]" & @CRLF & _
"["\"B"]" & @CRLF & _
"["\\"B"]" & @CRLF & _
"["\\\"B"]" & @CRLF & _
"["\\\\"B"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")