import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[\\[,])\\s*(['\\\"])(?:(\\1)|.)*?\\1(?=\\s*[,\\]])";
final String string = "[ \"A\", \"\"B\"\",'C' , \" D\"]\n"
+ "[ \"A\", \"'B'\",'C' , \" D\"]\n"
+ "[ \"A\", ''B'','C' , \" D\"]\n"
+ "[ \"A\", '\"B\"','C' , \" D\"]\n"
+ "[ \"A\", '8 o'clock','C' , \" D\"]\n"
+ "[ \"A\", \"Ol' 8 o'clock\",'C' , \" D\"]\n\n"
+ "[\"Some Text\"]\n"
+ "[\"Some more Text\"]\n"
+ "[\"Even more text about \\\"this text\\\"\"]\n"
+ "[\"Ol' 8 o'clock\"]\n"
+ "['8 o'clock']\n"
+ "[ '8 o'clock']\n"
+ "['Ol' 8 o'clock']\n"
+ "[\"\"B\"]\n"
+ "[\"\\\"B\"]\n"
+ "[\"\\\\\"B\"]\n"
+ "[\"\\\\\\\"B\"]\n"
+ "[\"\\\\\\\\\"B\"]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}