using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[\[,])\s*(['\""])(?:(\1)|.)*?\1(?=\s*[,\]])";
string input = @"[ ""A"", ""B"",'C' , "" D""]
[ ""A"", ""'B'"",'C' , "" D""]
[ ""A"", ''B'','C' , "" D""]
[ ""A"", '""B""','C' , "" D""]
[ ""A"", '8 o'clock','C' , "" D""]
[ ""A"", ""Ol' 8 o'clock"",'C' , "" D""]
[""Some Text""]
[""Some more Text""]
[""Even more text about \""this text\""]
[""Ol' 8 o'clock""]
['8 o'clock']
[ '8 o'clock']
['Ol' 8 o'clock']
[""B""]
[""\""B""]
[""\\""B""]
[""\\\""B""]
[""\\\\""B""]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}