const regex = new RegExp('(?<=[\\[,])\\s*([\\'\\"])(?:(\\1)|.)*?\\1(?=\\s*[,\\]])', 'gm')
const str = `[ "A", ""B"",'C' , " D"]
[ "A", "'B'",'C' , " D"]
[ "A", ''B'','C' , " D"]
[ "A", '"B"','C' , " D"]
[ "A", '8 o'clock','C' , " D"]
[ "A", "Ol' 8 o'clock",'C' , " D"]
["Some Text"]
["Some more Text"]
["Even more text about \\"this text\\""]
["Ol' 8 o'clock"]
['8 o'clock']
[ '8 o'clock']
['Ol' 8 o'clock']
[""B"]
["\\"B"]
["\\\\"B"]
["\\\\\\"B"]
["\\\\\\\\"B"]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}