import Foundation
let pattern = #"(?<=[\[,])\s*(['\"])(?:(\1)|.)*?\1(?=\s*[,\]])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[ "A", ""B"",'C' , " D"]
[ "A", "'B'",'C' , " D"]
[ "A", ''B'','C' , " D"]
[ "A", '"B"','C' , " D"]
[ "A", '8 o'clock','C' , " D"]
[ "A", "Ol' 8 o'clock",'C' , " D"]
["Some Text"]
["Some more Text"]
["Even more text about \"this text\""]
["Ol' 8 o'clock"]
['8 o'clock']
[ '8 o'clock']
['Ol' 8 o'clock']
[""B"]
["\"B"]
["\\"B"]
["\\\"B"]
["\\\\"B"]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)