$re = '/(?<=[\[,])\s*([\'\"])(?:(\1)|.)*?\1(?=\s*[,\]])/m';
$str = '[ "A", ""B"",\'C\' , " D"]
[ "A", "\'B\'",\'C\' , " D"]
[ "A", \'\'B\'\',\'C\' , " D"]
[ "A", \'"B"\',\'C\' , " D"]
[ "A", \'8 o\'clock\',\'C\' , " D"]
[ "A", "Ol\' 8 o\'clock",\'C\' , " D"]
["Some Text"]
["Some more Text"]
["Even more text about \\"this text\\""]
["Ol\' 8 o\'clock"]
[\'8 o\'clock\']
[ \'8 o\'clock\']
[\'Ol\' 8 o\'clock\']
[""B"]
["\\"B"]
["\\\\"B"]
["\\\\\\"B"]
["\\\\\\\\"B"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);