use strict;
my $str = '[ "A", ""B"",\'C\' , " D"]
[ "A", "\'B\'",\'C\' , " D"]
[ "A", \'\'B\'\',\'C\' , " D"]
[ "A", \'"B"\',\'C\' , " D"]
[ "A", \'8 o\'clock\',\'C\' , " D"]
[ "A", "Ol\' 8 o\'clock",\'C\' , " D"]
["Some Text"]
["Some more Text"]
["Even more text about \\"this text\\""]
["Ol\' 8 o\'clock"]
[\'8 o\'clock\']
[ \'8 o\'clock\']
[\'Ol\' 8 o\'clock\']
[""B"]
["\\"B"]
["\\\\"B"]
["\\\\\\"B"]
["\\\\\\\\"B"]';
my $regex = qr/(?<=[\[,])\s*(['\"])(?:(\1)|.)*?\1(?=\s*[,\]])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}