package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0\D]+`)
var str = `DE73456
DE71238
FR00034
FR00036
ES00038
US00039
DE00098`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}