import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0\\D]+";
final String string = "DE73456\n"
+ "DE71238\n"
+ "FR00034\n"
+ "FR00036\n"
+ "ES00038\n"
+ "US00039\n"
+ "DE00098";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}