import re
regex = re.compile(r"^[0\D]+", flags=re.MULTILINE)
test_str = ("DE73456\n"
"DE71238\n"
"FR00034\n"
"FR00036\n"
"ES00038\n"
"US00039\n"
"DE00098")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)