const regex = /^[0\D]+/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0\\D]+', 'mg')
const str = `DE73456
DE71238
FR00034
FR00036
ES00038
US00039
DE00098`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);