# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s(we.+tomorow)\s/What_I_added_/gmi;t' <<< "Today we have a rainy day but maybe tomorow will be sunny."