#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)\s(we.+tomorow)\s"
Local $sString = "Today we have a rainy day but maybe tomorow will be sunny."
Local $sSubst = "What_I_added_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)