re = /\s(we.+tomorow)\s/mi
str = 'Today we have a rainy day but maybe tomorow will be sunny.'
subst = 'What_I_added_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result