const regex = new RegExp('\\s(we.+tomorow)\\s', 'gmi')
const str = `Today we have a rainy day but maybe tomorow will be sunny.`;
const subst = `What_I_added_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);