using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s(we.+tomorow)\s";
string substitution = @"What_I_added_";
string input = @"Today we have a rainy day but maybe tomorow will be sunny.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}