import Foundation
let pattern = #"\s(we.+tomorow)\s"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"Today we have a rainy day but maybe tomorow will be sunny."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"What_I_added_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)