package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\s(we.+tomorow)\s`)
var str = `Today we have a rainy day but maybe tomorow will be sunny.`
var substitution = "What_I_added_"
fmt.Println(re.ReplaceAllString(str, substitution))
}