#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((MR|VR) )?((LAS|VIE|FAD) (([A-Z])|(\d{1,3})).\d{1,3}.\d{1,3}){1}.*" & @CRLF & _
""
Local $sString = "" & @CRLF & _
"Matches:" & @CRLF & _
"MR LAS 1.1.1 4P" & @CRLF & _
"MR LAS A.0.1 4P" & @CRLF & _
"MR LAS 1.01.01 4P" & @CRLF & _
"Prefix MR LAS 1.01.01 4P" & @CRLF & _
"Prefix MR LAS E.01.01 4P Kürbis" & @CRLF & _
"MR LAS 1.01.01 4P Postfix" & @CRLF & _
"MR LAS E.01.01 4P Kürbis Postfix" & @CRLF & _
"Prefix MR LAS 1.01.01 4P" & @CRLF & _
"Prefix MR LAS E.01.01 4P Kürbis" & @CRLF & _
"MR x LAS 1.01.01 4P" & @CRLF & _
"" & @CRLF & _
"Fails:" & @CRLF & _
"MR LAS 1.A.1 4P" & @CRLF & _
"MR LAS A..1 4P" & @CRLF & _
"MR LAS x1.01.01 4P" & @CRLF & _
"MR LAS 1.x.01 4P" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")