import re
regex = re.compile((r"((MR|VR) )?((LAS|VIE|FAD) (([A-Z])|(\d{1,3})).\d{1,3}.\d{1,3}){1}.*\n"), flags=re.MULTILINE)
test_str = ("\n"
"Matches:\n"
"MR LAS 1.1.1 4P\n"
"MR LAS A.0.1 4P\n"
"MR LAS 1.01.01 4P\n"
"Prefix MR LAS 1.01.01 4P\n"
"Prefix MR LAS E.01.01 4P Kürbis\n"
"MR LAS 1.01.01 4P Postfix\n"
"MR LAS E.01.01 4P Kürbis Postfix\n"
"Prefix MR LAS 1.01.01 4P\n"
"Prefix MR LAS E.01.01 4P Kürbis\n"
"MR x LAS 1.01.01 4P\n\n"
"Fails:\n"
"MR LAS 1.A.1 4P\n"
"MR LAS A..1 4P\n"
"MR LAS x1.01.01 4P\n"
"MR LAS 1.x.01 4P\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")