import Foundation
let pattern = #"""
((MR|VR) )?((LAS|VIE|FAD) (([A-Z])|(\d{1,3})).\d{1,3}.\d{1,3}){1}.*
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Matches:
MR LAS 1.1.1 4P
MR LAS A.0.1 4P
MR LAS 1.01.01 4P
Prefix MR LAS 1.01.01 4P
Prefix MR LAS E.01.01 4P Kürbis
MR LAS 1.01.01 4P Postfix
MR LAS E.01.01 4P Kürbis Postfix
Prefix MR LAS 1.01.01 4P
Prefix MR LAS E.01.01 4P Kürbis
MR x LAS 1.01.01 4P
Fails:
MR LAS 1.A.1 4P
MR LAS A..1 4P
MR LAS x1.01.01 4P
MR LAS 1.x.01 4P
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)