$re = '/((MR|VR) )?((LAS|VIE|FAD) (([A-Z])|(\d{1,3})).\d{1,3}.\d{1,3}){1}.*
/m';
$str = '
Matches:
MR LAS 1.1.1 4P
MR LAS A.0.1 4P
MR LAS 1.01.01 4P
Prefix MR LAS 1.01.01 4P
Prefix MR LAS E.01.01 4P Kürbis
MR LAS 1.01.01 4P Postfix
MR LAS E.01.01 4P Kürbis Postfix
Prefix MR LAS 1.01.01 4P
Prefix MR LAS E.01.01 4P Kürbis
MR x LAS 1.01.01 4P
Fails:
MR LAS 1.A.1 4P
MR LAS A..1 4P
MR LAS x1.01.01 4P
MR LAS 1.x.01 4P
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);