const regex = /((MR|VR) )?((LAS|VIE|FAD) (([A-Z])|(\d{1,3})).\d{1,3}.\d{1,3}){1}.*
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((MR|VR) )?((LAS|VIE|FAD) (([A-Z])|(\\d{1,3})).\\d{1,3}.\\d{1,3}){1}.*
', 'gm')
const str = `
Matches:
MR LAS 1.1.1 4P
MR LAS A.0.1 4P
MR LAS 1.01.01 4P
Prefix MR LAS 1.01.01 4P
Prefix MR LAS E.01.01 4P Kürbis
MR LAS 1.01.01 4P Postfix
MR LAS E.01.01 4P Kürbis Postfix
Prefix MR LAS 1.01.01 4P
Prefix MR LAS E.01.01 4P Kürbis
MR x LAS 1.01.01 4P
Fails:
MR LAS 1.A.1 4P
MR LAS A..1 4P
MR LAS x1.01.01 4P
MR LAS 1.x.01 4P
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}