#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^PAT_A_[^;\n]*(?:\n(?![^\n;]*NOT_MATCH_THIS)[^;\n]*)*\n[^;\n]*PAT_B.*(?:[^;]*);"
Local $sString = "PAT_A_YYY(" & @CRLF & _
" OK," & @CRLF & _
" PAT_B" & @CRLF & _
");" & @CRLF & _
"" & @CRLF & _
"PAT_A_XXX(" & @CRLF & _
" NOT_MATCH_THIS," & @CRLF & _
" PAT_B" & @CRLF & _
");"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")