const regex = /^PAT_A_[^;\n]*(?:\n(?![^\n;]*NOT_MATCH_THIS)[^;\n]*)*\n[^;\n]*PAT_B.*(?:[^;]*);/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^PAT_A_[^;\\n]*(?:\\n(?![^\\n;]*NOT_MATCH_THIS)[^;\\n]*)*\\n[^;\\n]*PAT_B.*(?:[^;]*);', 'gm')
const str = `PAT_A_YYY(
OK,
PAT_B
);
PAT_A_XXX(
NOT_MATCH_THIS,
PAT_B
);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}