using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^PAT_A_[^;\n]*(?:\n(?![^\n;]*NOT_MATCH_THIS)[^;\n]*)*\n[^;\n]*PAT_B.*(?:[^;]*);";
string input = @"PAT_A_YYY(
OK,
PAT_B
);
PAT_A_XXX(
NOT_MATCH_THIS,
PAT_B
);";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}